nmtysh.log

Tech系のネタや日々の独り言などを書いています。

rails generate に失敗する

Ubuntu 11.04 で rails generate したときにこんなエラーが表示されました。

${HOME}/.rvm/gems/ruby-1.9.3-p194/gems/execjs-1.3.2/lib/execjs/runtimes.rb:50:in `autodetect': Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)


そんな場合の対処。

$ gem install execjs
$ sudo apt-get install nodejs


参考:
ruby on rails 3.1 - ExecJS and could not find a JavaScript runtime - Stack Overflow

広告を非表示にする